Basic VLT example
With Dell EMC SmartFabric OS you can combine two Ethernet switches to appear externally as one switch - the technology is called VLT (Virtual Link Trunking). This is important to configure a LACP port channel spanning two switches. Another way to accomplish this would be "stacking" but with stacked switches you always update firmware on all switches at once and even in redundant configurations you will need to schedule downtime.
Cisco, for example, has a similar technology called vPC (virtual Port Channel) on their Nexus Ethernet Switches and so do all other major networking manufacturers (HP calls it Distributed Trunk).
VLTi
First we need to create a connection between our switches called VLTi (VLT interlink). In this example I use port 1/1/9 on both switches.
The parameters flowcontrol receive off, flowcontrol transmit off and mtu 9216 are not really needed as the link will have no flow control anyway and the MTU will be the maximum on VLTi, but I tend to explicitly set this - just in case.
Both switches
interface ethernet1/1/9
description VLTi
no shutdown
no switchport
mtu 9216
flowcontrol receive off
flowcontrol transmit off
Heartbeat
Next you should define interfaces for a heartbeat connection so the switches can communicate even in the event of an outtake of the VLTi interface(s).
As I intend to use in-band-management, the out-of-band-ports are unused and I can use them exclusively for my heartbeat. If you have a separate management network, you can configure management ip addresses on the out-of-band ports and still use them as heartbeat addresses.
Switch 1
interface mgmt1/1/1
description Heartbeat
no shutdown
no ip address dhcp
ip address 192.168.0.1/30
ipv6 address autoconfig
Switch 2
interface mgmt1/1/1
description Heartbeat
no shutdown
no ip address dhcp
ip address 192.168.0.2/30
ipv6 address autoconfig
VLT Domain
And finally you cover the main configuration in regards to the VLT domain.
The domain ID is not important but it is recommended to use different IDs for separate VLT switch pairs in your networking environment.
The backup destination is the heartbeat address of the other switch of the VLT pair.
The discovery-interface specifies which Ethernet port(s) you want to use for your VLTi.
The primary-priority values are optional but recommended - the lower the number, the higher the priority. I tend to use 4096 on the primary and 8192 on the secondary switch - just to be coherent with my Spanning-Tree setups.
The vlt-mac is also optional but recommended. On a reboot the switch will use its own MAC address as VLT MAC address, but if your secondary switch boots up first and afterwards the primary switch comes up, chances are the MAC address will change. The downstream switches on the LACP port channel will notice a MAC address change and temporarily inconsistency. Depending of the configuration on your downstream switch this may cause a permanent loss of connection.
A lot of examples use a MAC address like 00:11:22:33:44:55 - which will work but are in the range of vendor specific MAC addresses. I would recommend to use "private" MAC addresses based on your system MAC address in any cases. I've got the recommendation from Documentation for the previous Dell Networking OS 9 (the successor of Force10 OS) - I wish official documentation from Dell Technologies would adhere to those old rules still.
Switch 1
vlt-domain 1
backup destination 192.168.0.2
discovery-interface ethernet1/1/9
primary-priority 4096
vlt-mac 0e:41:40:05:00:00
Switch 2
vlt-domain 1
backup destination 192.168.0.1
discovery-interface ethernet1/1/9
primary-priority 8192
vlt-mac 0e:41:40:05:00:00
Defining a Port Channel spanning two switches
Now you can configure a port channel spanning two switches.
The vlt-port-channel defines the number of the port channel on the other switch to be used - in general this is the same number as on the first one.
Both switches
interface port-channel1
no shutdown
switchport mode trunk
switchport access vlan 1
switchport trunk allowed vlan 10
mtu 9216
vlt-port-channel 1
!
interface ethernet1/1/1
no shutdown
channel-group 1 mode active
no switchport
mtu 9216
flowcontrol receive off